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PLEASE NOTE: 

This print station is for customer supplied paper. There is no paper installed by default.



Display Color
The computer monitors in the SB and DPL are color calibrated once a semester to give 
you the most accurate on screen representation of how your image will print out. 
You must set the Display in order to view your image with this color setting.

1. Go to System Preferences
2. Select Displays
3. Adjust the Brightness slider to the level taped to the computer (it should a bit to the 
right of center), and uncheck “Automatically adjust brightness”
4. Select the Color tab, and choose the most recent “_MCAD_Xdate...” Display Profile 
(the most recent calibration should appear at the top of the list)
5. Close the System Preferences window, done!



1. In Photoshop Edit > Color Settings
2. Settings: “North American Prepress 2”
3. Color Management Policies: “Convert to Working...” for each color space

When you open your files in Photoshop, this message may appear, make sure you are 
converting to the working space, and hit OK

Color Settings

For the most accurate color when printing, we recommend adjusting the Color Setting in 
Photoshop (or other Adobe program) to convert to the working spaces.
See our KnowledgeBase article on Color Spaces for more information about why we rec-
ommend working in Adobe RGB (1998) for all print projects at MCAD.

https://intranet.mcad.edu/kb/cmyk-vs-rgb-what-color-space-should-i-work


The Epson printers are local printers, connected via USB to this computer station only. 
You cannot print to them from your laptop, or other computer stations.
You will need to transfer your files onto this computer station in order to print.

Easy file transfer methods:
• MCAD studio server  (this is the recommended method)
Connect to your studio server from your laptop to place files into your server space, 
then connect on this desktop computer to retrieve the files
	 From Finder: 
		  Command+K (or Go>Connect to Server)
		  Select (or type in) studio.mcad.edu
		  Log in with your MCAD user account information

• Google Drive 
Make sure you have your phone and/or laptop handy, as this method requires two-
step verification when logging into an unknown device

• External Hard Drive or Thumb Drive
	 Plug external drives into the computer only (see back of computer for ports)

• Dropbox or other web based servers

You must download your files into this computer before opening them.
External hard drives and servers are not powerful enough to process the print. 
If you open your file from an external location you risk causing communication errors 
and glitchy or partial prints.  

PLEASE BE AWARE:
Files saved to the desktop on this computer can only be accessed by you while you are 
logged in to this computer station. 
Files are deleted from the computer cache periodically, do not use this computer 
station as a safe storage option. 
If you made updates or changes to your file during your print session, make sure to 
save that print ready file to your server or other file storage location.

Accessing Your Files

https://intranet.mcad.edu/kb/studio-server


1. Load a sheet of 8.5x11 or 11x17 scrap paper to print check pattern, see page 6

2. From the little LCD touch screen on the printer 
	 Select Menu > Maintenance > Print Head Nozzle Check.

3. Select Start. The nozzle pattern will print.

4. Check the printed pattern to see if there are gaps in the lines.
Print head is clean

Print head needs cleaning

5. Do one of the following:
• If there are no gaps, select O to exit.
• If there are gaps or the pattern is faint, select X to perform head cleaning.

6. Follow the instructions on the screen to clean the print head, check the nozzles, 
and repeat the process as necessary.

Printing a Nozzle Check pattern prior to printing is standard practice for professional 
printing. We recommend printing a nozzle check at the beginning of a print session, or if 
you notice your print quality has declined. 
Please contact SB staff if you need assistance.

Nozzle Check



This printer is for customer supplied paper, it does not have paper loaded by default.
The Service Bureau sells sheets of paper for this printer, but most customer supplied 
photo paper or inkjet safe material will work. 
Inkjet safe material includes, but is not limited to: photo paper of any brand, uncoated 
drawing/watercolor paper, sticker paper, illustration board, inkjet transparency, etc. 

Loading Paper - Sheets

Sheet Paper (Roll paper instructions can be found on page 14)

Always load cut sheet paper in portrait orientation (short edge first)
Sheet must be flat/no curl
Edges cannot be rough/deckled
Corners should be 90° angles
Sheet dimensions must be between 8x8” - 24x96”

1. Select the paper information area on the LCD screen

2. Select Cut Sheet

3. Open the cut sheet cover

4. Feed the sheet into the right side of the paper feed slot until it meets resistance. 
Align the right edge of the sheet with the vertical line on the roll paper cover as 
shown. Printable side of the sheet should be visible

5. Select Complete > OK on the LCD screen

6. Select a paper type and paper size that best matches 
the loaded paper. If you need to adjust any specific 
settings, select Advanced Paper Settings

7. To remove a cut sheet from the printer, support 
the paper so it doesn’t fall, then select the paper 
information area on the LCD screen and select Remove



Follow these instructions, in the correct order, and you should get a pretty perfect print! 
Please make an appointment with SB staff if you would like a one-on-one tutorial with 
this advanced equipment. 
Pop into the SB, during business hours, if you would like staff to double check your print 
settings before hitting print.
If you run into any issues, please reach out to staff ASAP for assistance.

1. Turn the printer on
	 - Log in to the computer station with your MCAD short username/password
	 - Download your files to Temp Storage hard drive

- If you are downloading files from a web resource (google drive, dropbox, 
etc.) you will need to change the download location to Temp Storage in your 
browser preferences
- We recommend using your studio.mcad.edu server to transfer files from 
your laptop to this computer station quickly and easily

	 - Run a Nozzle Check (and Head Cleaning if necessary)

2. Open your image in Photoshop
	 - Log in to Photoshop
		  - MCAD email (ex. jdoe@mcad.edu) press Return key
		  - MCAD short username and password (ex. jdoe)
	 - Set color settings, found on Page 3
	 - Open files from Temp Storage
	 - Recommended file prep before printing
		  Image > Mode: RGB Color, 8 Bit/Channel
		  File Format: TIFF
		  Layers: Flattened
		  We recommend including a border in your file

3. Load Paper
	 See Page 6 for details
	 The following instructions focus on printing on sheets of paper only. 
	 If you have roll paper to use, print instructions can be found on page 13. 

Printing Instructions - Sheet Paper



5. File > Print

Select these settings in the print window that pops up:

a. Printer:  Epson SC-P7500 Series

b. Layout: Choose what is best for your image (ignore the preview image until you 

have selected your paper size in the next steps)

c. Color Handling: Photoshop Manages Colors

d. Printer Profile: Epson SC-P9500_7500 YOUR MEDIA HERE

You may notice slight color shifts in your image after setting Proof Setup, and with the 
calibrated computer display, any final color adjustments or fine tuning to your image 
should be done now (using Levels, Curves, etc).

4. View > Proof Setup > select paper type 
Select the recommended paper setting for your media, or closest equivalent. 
You may ask SB staff for a recommendation if unsure.

Scroll
Bar

a.

b.

c.
d.



6.  Print Settings...

Printer: EPSON  SC-P7500 Series
Click Show Details to expand the 
window for the next steps

Select the Print Settings button to open an additional print window

Click the Layout dropdown, and 
select Printer Settings
to access the next settings



7. Paper Size: 

Select a pre-set paper size from the dropdown menu, or create a custom paper size

For pre-set sizes, you must select a “(Sheet)” option

Select your paper size

Please note, you must be 
exact - please double check 
your paper measurements!

Most commercial paper will 
have pre-set sizes available

If you are using a sheet you 
have cut down, you will need 
to make a custom paper size



Under the Basic tab
a. Page Setup: Sheet (pre-set paper sizes will auto select, you may need to manually 
select “Sheet” for custom paper sizes)
b. Media Type: Choose the paper type
c. Print Quality: Quality Options (will reveal speed/quality slider)
d. SuperFine - 1200dpi will work great for most projects (choosing a lower dpi will 
print faster with lower quality, higher dpi will print slower with higher quality)
e. Optional settings 

	 Paper Edge Quality: Standard
	 High Speed: Check for double time printing (recommended)
	 Finest Detail: Sharpens edges. Use for text, line-work, or vector based images

f. Click Save to continue

8. Printer Settings:

b.

c.

d.

e.

f.

a.



If you are confident that you followed the settings accurately go ahead and...

9. Hit Print!
	 Please remember to log out of the computer, and turn the printer off when done!

Final settings check: 
Look at your previewed image, make sure nothing is being cut off
Rotate the Layout if necessary
Optional: scroll down to add crop/trim marks (the paper size you selected or created 
needs to be larger than image size for crop/trim marks to print)
If you would like SB staff to double check your settings, now is the time!

Troubleshooting: 
- Nothing printing? Check your PaperCut account - you may need to add money 
- Print looking wrong? Cancel/Pause the print ASAP! 

Did you do a nozzle check? If the nozzles are clogged prints will look bad
Did you follow the instructions accurately? Go back through and double check 
Check out the troubleshooting section on Page 26
Save your bad print to show SB staff so we can advise you appropriately
Request a refund for printer errors through your PaperCut account

https://papercut.mcad.edu:9192/user
https://intranet.mcad.edu/kb/how-request-refund-bad-or-mis-printed-prints


Please make an appointment with SB staff if you would like a one-on-one tutorial with 
this advanced equipment. 
If you run into any issues, please reach out to staff ASAP for assistance.
You will need to check out the Roll Media Adapters from the SB.

1. Turn the printer on
	 - Log in to the computer station with your MCAD short username/password
	 - Download your files to Temp Storage hard drive

- If you are downloading files from a web resource (google drive, dropbox, 
etc.) you will need to change the download location to Temp Storage in your 
browser preferences
- We recommend using your studio.mcad.edu server to transfer files from 
your laptop to this computer station quickly and easily

	 - Run a Nozzle Check (and Head Cleaning if necessary)

2. Open your image in Photoshop
	 - Log in to Photoshop
		  - MCAD email (ex. jdoe@mcad.edu) press Return key
		  - MCAD short username and password (ex. jdoe)
	 - Set color settings, found on Page 3
	 - Open files from Temp Storage
	 - Recommended file prep before printing
		  Image > Mode: RGB Color, 8 Bit/Channel
		  File Format: TIFF
		  Layers: Flattened
		  We recommend including a border in your file

Instructions continue on next page ---->

Printing Instructions - Roll Paper



1. Open the roll paper cover
2. Unlock and slide the roll paper holder to the left using the handle 
3. Adjust Roll Media Adapters to fit the core size of your roll paper
4. Release tension levers on Roll Media Adapters and push into paper core on both 
ends, then push down on tension levers to secure
5. Gently place roll in position between roll paper holders
6. Slide roll paper holder to right, making sure both ends are secured in adapters
7. Pull up the lock lever on the roll paper holder to lock it in place
8. Press Set on the control panel to unlock the paper feed slot
9. Insert the leading edge of the paper into the paper feed slot until you hear a sound
10. Make sure the roll paper is taut, and close roll paper cover
11. On the LCD screen, select the paper type for the loaded paper
12. Select Advanced Paper Settings and set any additional settings, if necessary
13. Select OK when you are finished

Remove your roll paper when finished printing
1. On the LCD screen, select the paper information area and select Remove
2. Open the roll paper cover
3. We recommend wrapping a sheet of protective paper around your roll at this point
4. Unlock roll paper holder and slide to left
5. Carefully lift roll out of printer
6. Remove Roll Media Adapters using tension levers
7. Raise lock lever on adapter holder
8. Close roll paper cover
10. Return Roll Media Adapters to SB staff

3. Load Paper

- You will need to request the Roll Media Adapters from SB staff during business 
hours, please return them when you are done with your printing session

- You can load roll paper with a 2- or 3-inch core and a width of up to 24 inches

- Full roll media loading instructions with pictures/diagrams can be found here, please 
ask for SB Staff assistance if you are loading roll paper for the first time

https://files.support.epson.com/docid/cpd5/cpd58368.pdf#page=39&zoom=100,0,437


5. File > Print

Select these settings in the print window that pops up:

a. Printer:  Epson SC-P7500 Series

b. Layout: Choose what is best for your image (ignore the preview image until you 

have selected your paper size in the next steps)

c. Color Handling: Photoshop Manages Colors

d. Printer Profile: Epson SC-P9500_7500 YOUR MEDIA HERE

You may notice slight color shifts in your image after setting Proof Setup, and with the 
calibrated computer display, any final color adjustments or fine tuning to your image 
should be done now (using Levels, Curves, etc).

4. View > Proof Setup > select paper type 
Select the recommended paper setting for your media, or closest equivalent. 
You may ask SB staff for a recommendation if unsure.

Scroll
Bar

a.

b.

c.
d.



6.  Print Settings...

Printer: EPSON  SC-P7500 Series
Click Show Details to expand the 
window for the next steps

Select the Print Settings button to open an additional print window

Click the Layout dropdown, and 
select Printer Settings
to access the next settings



7. Paper Size: 

Select a pre-set paper size from the dropdown menu, or create a custom paper size

For pre-set sizes, please select the top option in the list, or a “Roll Paper” option

Best practice is to create a custom paper size - see page 21 for details

Select your paper size

Please note, the paper size 
that you select here directly 
reflects how PaperCut will 
charge your account, so it is 
often most cost effective to 
create a custom paper size



Under the Basic tab
a. Page Setup: Roll Paper (pre-set paper sizes will auto select, you will need to 
manually select “Roll Paper” for custom paper sizes)
b. Media Type: Choose the paper type
c. Print Quality: Quality Options (will reveal speed/quality slider)
d. SuperFine - 1200dpi will work great for most projects (choosing a lower dpi will 
print faster with lower quality, higher dpi will print slower with higher quality)
e. Optional settings 

	 Paper Edge Quality: Standard
	 High Speed: Check for double time printing (recommended)
	 Finest Detail: Sharpens edges. Use for text, line-work, or vector based images

f. Click the Printer Settings dropdown, and select Roll Paper Settings to continue

8. Printer Settings:

b.

c.

d.

e.

f.

a.



8. Roll Paper Settings:

Auto Cut Settings: Select one of these options
Normal Cut: Recommended (print will be cut from roll with a .5” margin)
Off: Useful when printing multiple/smaller files, must press  button on printer 
to manually cut paper from roll when print is complete
Double Cut: for borderless printing only (wastes paper)

Check boxes for your preferred options:
Auto Rotate: Recommended (best fit your image on the roll to conserve paper)
Print Page Line: Prints trim line between images, useful when cut setting is off
Save Roll Paper: Not Recommended - will ignore any white space/borders in image 

Select Save to continue



If you are confident that you followed the settings accurately go ahead and...

9. Hit Print!
	 Remove your paper
	 Please remember to log out of the computer, and turn the printer off when done!	
	 Return the Roll Media Adapters when you are finished.

Final settings check: 
Look at your previewed image, make sure nothing is being cut off
Rotate the Layout if necessary
Optional: scroll down to add crop/trim marks (the paper size you selected or created 
needs to be larger than image size for crop/trim marks to print)
If you would like SB staff to double check your settings, now is the time!

Troubleshooting: 
- Nothing printing? Check your PaperCut account - you may need to add money 
- Print looking wrong? Cancel/Pause the print ASAP! 

Did you do a nozzle check? If the nozzles are clogged prints will look bad
Did you follow the instructions accurately? Go back through and double check 
Check out the troubleshooting section on Page 26
Save your bad print to show SB staff so we can advise you appropriately
Request a refund for printer errors through your PaperCut account

https://papercut.mcad.edu:9192/user
https://intranet.mcad.edu/kb/how-request-refund-bad-or-mis-printed-prints


We recommend creating a custom paper size when printing on roll paper. It is the most 
cost effective, and gives you the most control over your work.
You will need to create a custom paper size for cut sheets of unusual sizes.

Step 6  in your 
print settings: 

From the Paper Size 
dropdown menu, 
select “Manage 
Custom Sizes...”
a new window will 
pop up: 

a. Press the + button to create a 
new paper size

b. Enter Width / Height
- For sheets you must enter the 
EXACT dimensions of paper
- For roll paper, we recommend 
making your page size slightly 
larger than your image

c. Enter Non-Printable Area 
- These are your margins, this 
area cuts into the defined 
paper size, it does not add 
area outside of the Paper Size 
Minimum allowed margins for 
sheets of paper:
	 Bottom: 0.56 in
	 Top: 0.25 in 
	 Left/Right: 0.00 in
The printer has to have an edge 
to hold on to on the bottom.

Hit OK when done 
Continue with Step 7 in 
your print settings

Custom Paper Size



If you ever find a paper that you want to use and we do not have a profile loaded for it, 
you should be able to download the specific icc profile for your paper from the paper 
company’s website. (ex. Hahnemuhle, Canson, Inkpress, or any other paper)
Your paper may have insert with instructions, or simply do a websearch for your paper 
brand/type + icc profile or pritning profile). 

1. Download your custom paper profile (icc profile).

2. Transfer the ICC profile to the correct folder.

• Go to the GO menu at the top of the Finder then click on LIBRARY.
• In the LIBRARY create a new folder (Cmd+Shift+N) and title it “ColorSync.”
• In that new ColorSync folder, create another new folder and title it “Profiles.”
• Copy your ICC profile into that new Profiles folder.

When done, your file path will look like this: Library > ColorSync > Profiles

You have to create these folders: Cmd+Shift+N

Custom Paper Profiles



3. Open an image in Photoshop, and go to View > Proof Setup > Custom...

Once in the Custom window, you will see something like this.  
Click on the “Device to Simulate” to get to a massive pulldown menu.



4. Find your new profile. 

5. Select your new profile, and your screen should look something like this:
(Your “Device to Simulate” will be your own custom profile name, but the other settings 
should be the same)



Once that is all set, click on “Save…” and it should automatically save your profile in 
the correct location.  
Name your file after the paper type that you are profiling (we named ours “Ink-
press-Luster.psf”).
You may want to save this file to your server or an external hard drive/thumb drive.

You may print just like before, only now you will use your custom profile in place of any 
other pre-loaded profile. Oh joy. Word. 

Click Save. 
You will need to re-load this saved .psf file each time you wish to print with it.



Use these additional/alternate settings, while following the Print Instructions listed 
on Pages 6-11 for all other settings.

Paper Size: Create Custom Paper Size
Width/Height: exact size of your image
Non-Printable Area: 0 in for all sides

Printer Settings: 
Page Setup: Roll Paper - Borderless, Auto Expand

Roll Paper Settings:
Auto Cut Settings: Double Cut
Borderless Enlargement Setting: Max

Creating a borderless print is only possible on roll paper.  

Please note: 
Allow for at least .125” bleed on all sides - printing borderless will enlarge your image 
slightly to bleed over the edges, you will lose information that is too close to the edges.

Borderless Printing



Advanced Black and White (ABW) mode on Epson printers is one of the best and easiest  
ways to print high quality, neutral toned, B&W prints. 

1. Follow pages 1-6 of this manual 

2. File > Print
Printer: EPSON SC-P7500 Series
Color Handling: Printer Manages Colors

3. Print Settings...
Follow steps 5-6
See page 12 for custom paper sizes

4. Color Matching
Select EPSON Color Controls

5. Printer Settings
Basic tab

Media Type: Choose your paper type
Color: Advanced B&W Photo
Color Toning: Neutral
Print Quality: Your choice - 
We recommend 1200-2800dpi
High Speed: Prints faster, may reduce 
quality

Advanced Color Settings tab
Tone: Dark

6. Save
	  Continue on page 11

Advanced B&W Printing



1. View > Proof Setup > Custom...
	 - Device to Simulate: choose appropriate paper type
	 - Uncheck all boxes, hit OK

- Turn printer on, log in to computer
- Download your fully Packaged INDD Folder to Temp Storage, open from that location

2. File > Print
	 Printer: EPSON SC-P7500 Series
   Color Management tab
	 Print: Proof
	 Color Handling: Let InDesign...
	 Printer Profile: Your paper type
	 Uncheck Simulate Paper Color
   Setup tab
	 Rotate orientation if necessary
	 Page Position: Centered

3. Page Setup... button (lower left)
	 see page 9 for pre-set sizes
	 see page 12 to create custom size

4. Printer... button
	 Expand window with “Show Details”
	 Layout dropdown to Printer Settings
	 see page 10
5. Hit Print (and again)

Please note: 
If you are printing a multi-page document, or double-sided photo book, we recommend 
using sheets vs. roll paper. We sell paper by the sheet in the SB (double-sided matte 
finish paper is available), or you are welcome to provide your own. 
If printing double-sided, let the prints dry for at least an hour before printing other side. 

Printing From InDesign

https://intranet.mcad.edu/kb/packaging-indesign-file


1. View > Proof Setup > Customize...
	 - Device to Simulate: choose paper type (MK) 
	 - Rendering Intent: Relative Colormetric
	 - Uncheck all boxes, hit OK

- Turn printer on, log in to computer
- Download your Packaged AI Folder or EPS file to Temp Storage before opening

2. File > Print
	 Printer: EPSON SC-P7500 Series
  Color Management tab
	 Color Handling: Let Illustrator...
	 Printer Profile: Your paper type
	 Rendering Intent: Relative Colormetric
  General tab
	 Choose Artboards to print or ignore
	 Rotate orientation if necessary

3. Page Setup... button (lower left)
	 see page 9 for pre-set sizes
	 see page 12 to create custom size

4. Setup... button
	 Expand window with “Show Details”
	 Layout dropdown to Printer Settings
	 see page 10
5. Hit Print (and again)

Please note: 
If you are printing a multi-page document, we recommend using sheets vs. roll paper. 
We sell paper by the sheet in the SB, or you are welcome to provide your own. 
If printing double-sided, let the prints dry for at least an hour before printing other side. 

Printing From Illustrator



Ink Low Warning
•	 An INK LOW message on the printer’s LCD display is not cause for concern
•	 When the ink cartridge is empty, printing will stop and the display will say INK OUT, 

the ink cartridge can be replaced and printing will resume seamlessly
•	 You may have to use a full ink cartridge in order to run a head cleaning, please re-

place the older/low ink cartridge after cleaning 

Troubleshooting

Replacing Ink
shake cartridge well

File Not Printing

If you went through all of the printing instructions accurately, hit print, and nothing is 
happening it could be a few different things.  

Do you have enough money in your Papercut Account? 
	 papercut.mcad.edu

Roll Paper too low to print? 
	 At 4 feet or less, the printer will wait for a new roll before resuming with 
printing, please notify SB staff if the paper appears to be too low to complete your 
print job - the paper length remaining will appear on the LCD screen on the printer

You are welcome to replace ink cartridges when necessary! We will leave replacement 
inks near the printer if we notice that it is getting low. 
Ask SB staff to assist you if you do not feel up to the challenge.

Printing on Transparencies
Use Enhanced Matte paper profile/media type for best results.
Load transparency sheets with notch in upper right or lower left corner so print 
surface faces out at you. 
You may need to use a carrier sheet behind the transparency sheet for the printer to 
read the edge, but for best results, try loading without a carrier sheet first.
Smaller sheets can be harder to load than larger sheets, if you have multiple images it 
may be best to print them all on a larger sheet.

https://papercut.mcad.edu:9192/user


Is your paper loaded correctly?
	 There will be an error message on the LCD screen, you may need to reload your 
sheet of paper if it is skewed. 
	 Double check your paper size, when setting up a custom paper size, you need to 
be sure that the paper size is set to exactly the size of your sheet.
File too big? 
	 If you have an extra large image to print (even if the file size is not extraordinary) 
it will take extra long to process and print, so please allow for that. 
	 If your file size is particularly large (1gb or higher), please make sure to flatten 
your file, delete any channels/adjustment layers.
	 File should be in 8 bit mode rather than 16 bit.
	 DPI should be 300 or around there (no less than 150, no more than 400).

Is your file on the Temp Storage on the computer?
	 If you are printing from a connected server or external hard drive, you can 
experience file corruption and server interruptions that can cause files to not print, or 
result in your print looking strange.

Nozzle check or head cleaning cycle not complete? 
	 Wait for it to complete, and return to the “ready” status menu

Printer not on? 
	 LOL it happens more than you would think

When in doubt, shoot the SB an email (sbureau@mcad.edu), pop over to the Service 
Bureau for extra assistance, or make an appointment for a printing demo.

Computer Issues
	 If you are experiencing issues with the computer, please contact computer 
support, or stop by the Help Desk during business hours.

Application Knowledge
	 If you need assistance with Adobe programs (beyond print setup) such as; 
file setup and creation, image resizing, color adjustments, or assignment specific 
issues and troubleshooting. Please refer to your professor/instructor, or make an 
appointment with the Learning Center.

mailto:sbureau%40mcad.edu?subject=Epson%20Printing%20Assistance%20Please
https://calendly.com/mcadsb
mailto:helpdesk%40mcad.edu?subject=
mailto:helpdesk%40mcad.edu?subject=
https://intranet.mcad.edu/department/help-desk
https://intranet.mcad.edu/department/learning-center-and-accessibility-services


These printers can reproduce a very wide range of colors, but you will find that there are certain 
tones that are not possible to translate from screen to print.

You always want your artwork files to be in RGB to give you 
the widest range of colors available on the screen. 

But remember that the printer uses CMYK inks to reproduce 
the colors seen on your screen. 

We do a “soft proof” with our preferred paper type, to see how our colors will translate. 
(View > Proof Setup step in print instructions)

Most of the time, you won’t notice much of a difference, if any!

If you do notice a difference, it means that the printer cannot reproduce that color on that paper 
type (PK finish papers will give a slightly wider color range), and you will need to make some 
adjustments to your file to get the color closer to what you prefer. 
We have noticed the most trouble with deep purpley-blue colors.

Try View > Gamut Warning to see what colors might be outside of the color gamut (or available 
color range).

Colors out of gam
ut

Standard view
Color Gamut Warnings



Epson Printer Errors
Head Strike (see “ink smudges”)
Print head causes streaks, commonly due to 
excessive curling or thickness of paper.
Recommended to flatten paper, adjust platen gap 
and wait for excess ink on print heads to dry.

Directions print head moves 

 (see “nozzle check”) Banding
Clogged print nozzles cause one or more color to 

not print, causing stripes and missing colors.
Run a nozzle check before printing to aviod. 

Remedy by running head cleaning, may need to run 
cleaning more that once. 

D
irections p

rint head
 m

oves 

Head Strikes or Banding



Print Appears Too Dark

If your prints are coming out really REALLY dark (much darker than the screen), you 
might be forgetting one, little, easy-to-forget step.

Color Management needs to be set before continuing to Print Settings:

Color Handling: Photoshop Manages Colors.

Printer Profile: Epson SC-P9500-7500 YOUR PAPER TYPE HERE

Often the Printer Profile is left at “Working RGB – Adobe RGB 1998,” which is wrong.  

Commonly 
Overlooked

Print Appears Too Light
If you are printing on an uncoated sheet of paper (e.g.. watercolor paper, drawing pa-
per, plain copy paper, etc), where the surface of the paper is not made to accept ink, 
the ink will be absorbed into the surface of the paper. 
Your print will appear lighter than your image on screen, with a slight stippled texture.
There is not much you can do to solve this, beyond printing on a coated photo paper. 

If you are using a coated photo paper, you may have accidentally printed on the back 
of your sheet, on the uncoated/non-printable side.
The printable surface should face out toward you when loading your paper.


