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Display Color
The computer moniters in the SB and DPL are color calibrated once a semester to give 
you the most accurate on screen representation of how your image will print out. 
You must set the Display in order to view your image with this color setting.

1. Go to System Preferences
2. Select Displays
3. Adjust the Brightness slider to the level taped to the computer (it should a bit to the 
right of center), and uncheck “Automatically adjust brightness”
4. Select the Color tab, and choose the most recent “_MCAD_Xdate...” Display Profile 
(the most recent calibration should appear at the top of the list)
5. Close the System Preferences window, done!



1. In Photoshop Edit > Color Settings
2. Settings: “North American Prepress 2”
3. Color Management Policies: “Convert to Working...” for each color space

When you open your files in Photoshop, this message may appear, make sure you are 
converting to the working space, and hit OK

Color Settings

For the most accurate color when printing, we reccomend adjusting the Color Setting in 
Photoshop (or other Adobe program) to convert to the working spaces.
See our KnowledgeBase article on Color Spaces for more information about why we 
recommend working in Adobe RGB (1998) for all print projects at MCAD.

https://intranet.mcad.edu/kb/cmyk-vs-rgb-what-color-space-should-i-work


You must download your files into the Temp Storage hard drive folder on this 
computer before opening them.
Opening your file from an external hard drive, web browser, or your MCAD server will 
not work for printing. 
External drives/servers are not powerful enough to process the print, and you risk 
causing communcation errors and glitchy or partial prints.  

Place your files in here! 

Temp_Storage is the local 

storage (hard drive) on this 

physical computer.

to reiterate:

ONLY PRINT FROM TEMP_STORAGE!

We reccommend using your MCAD studio server space to transfer files from your 
laptop to the desktop computer quickly and easily! 
 From Finder: 
  Command+K (or Go>Connect to Server)
  Select (or type in) studio.mcad.edu
  Log in with your MCAD user account information

Other methods of transferring files onto this computer include: 
 - Google Drive (make sure you have your phone and/or laptop handy, as this 
method often requires two-step verification when logging into an unknown device)

 - External Hard Drive or Thumb Drive
 - Dropbox or other web based servers

In all instances, make sure you are downloading your files into the Temp_Storage hard 
drive, and opening them from that location.

Accessing Your Files

https://intranet.mcad.edu/kb/studio-server


1. From the little LCD touch screen on the printer 
 Select Menu > Maintenance > Print Head Nozzle Check.

2. Select Start. The nozzle pattern will print.

3. Check the printed pattern to see if there are gaps in the lines.

Print head is clean

Print head needs cleaning

4. Do one of the following:
• If there are no gaps, select O to exit.
• If there are gaps or the pattern is faint, select X to perform head cleaning.

5. Follow the instructions on the screen to clean the print head, check the nozzles, 
and repeat the process as necessary.

Printing a Nozzle Check pattern prior to printing is standard practice for professional 
printing. We recommend printing a nozzle check at the beginning of a print session, or if 
you notice your print quality has declined. 
Please contact SB staff if you need assistance.

Nozzle Check



Follow these instructions, in the correct order, and you should get a pretty perfect print! 
Please make an appointment with SB staff if you would like a one-on-one tutorial with 
this advanced equipment. 
Pop into the SB, during business hours, if you would like staff to double check your print 
settings before hitting print.
If you run into any issues, please reach out to staff ASAP for assistance.

You may notice slight color shifts in your image after setting Proof Setup, and with the 
calibrated computer display, any final color adjustments or fine tuning to your image 
should be done now (using Levels, Curves, etc).

3. View > Proof Setup > select paper type:

  Epson Enhanced Matte

1. Turn the printer on
 - Log in to the computer station with your MCAD short username/password
 - Download your files to Temp Storage hard drive
 - Run a Nozzle Check (and Head Cleaning if neccessary)

2. Open your image in Photoshop
 - Log in to Photoshop
  - MCAD email (ex. jdoe@mcad.edu) press Return key
  - MCAD short username and password (ex. jdoe)
 - Open files from Temp Storage
 - Reccommended file prep before printing
  Image > Mode: RGB Color, 8 Bit/Channel
  File Format: TIFF
  Layers: Flattened

Printing Instructions



4. File > Print

Select these settings in the print window that pops up:

a. Printer:  Epson SC-P7500 Series

b. Layout: Choose what is best for your image (ignore the preview image until you 

have selected your paper size in the next steps)

c. Color Handling: Photoshop Manages Colors

d. Printer Profile: Epson SC-P9500_7500 Enhanced Matte Paper 

Note: This print station uses Matte Black ink and Epson Enhanced Matte Paper only. 

If you need a Luster finish paper, or other material, please use a different printer.

Instructions continue on next page -->

Scroll
Bar

a.

b.

c.
d.



5.  Print Settings...
Select the Print Settings button to open an additional print window

6. Paper Size: 

Select a pre-set paper size from the dropdown menu, or create a custom paper size

Please note, the paper size you select 
is the area PaperCut uses to calculate 
print cost, so it is often most cost 
effective to create a custom paper size! 

For pre-set sizes, please select the top option in the list, or a “Roll Paper” option



Scroll down to access the additional options - 

1. Click on Printer Options to expand the menu

2. Select Printer Settings

1. expand

2. click to 
access next 
menu

*psst. 
Roll Paper 
Settings will be 
the next move

7. Printer Settings:



Under the Basic tab

a. Page Setup: Roll Paper (pre-set paper sizes will auto select, you will need to 

manually select “Roll Paper” for custom paper sizes)

b. Media Type: Choose the paper type: Enhanced Matte Paper
c. Print Quality: Quality Options (will reveal speed/quality slider)

d. SuperFine - 1200dpi will work great for most projects (choosing a lower dpi will 

print faster with lower quality, higher dpi will print slower with higher quality)

e. Optional settings 
 Paper Edge Quality: Standard

 High Speed: Check for double time printing (recommended)

 Finest Detail: Sharpens edges. Use for text, linework, or vector based images

f. Click OK to continue to Roll Paper Settings

b.

c.

d.

e.

f.

a.



If you are confident that you followed the settings accurately go ahead and...

8. Hit Print!
 Please remember to log out of the computer, and turn the printer off when done!

Final settings check: 
Look at your previewed image, make sure nothing is being cut off
Rotate the Layout if neccessary
Optional: scroll down to add crop/trim marks (the paper size you selected or created 
needs to be larger than image size for crop/trim marks to print)
If you would like SB staff to double check your settings, now is the time!

Troubleshooting: 
- Nothing printing? Check your PaperCut account - you may need to add money 
- Print looking wrong? Cancel/Pause the print ASAP! 

Did you do a nozzle check? If the nozzles are clogged prints will look bad
Did you follow the instructions accurately? Go back through and double check 
Check out the troubleshooting section on Page 17
Save your bad print to show SB staff so we can advise you appropriately
Request a refund for printer errors through your PaperCut account

https://papercut.mcad.edu:9192/user
https://intranet.mcad.edu/kb/how-request-refund-bad-or-mis-printed-prints


We reccommend creating a custom paper size when printing on any of our Epson 
Printers. It is the most cost effective, and gives you the most control over your work.

Custom Paper Size

Step 6  in your print 
settings: 

From the Paper Size 
dropdown menu, select 
“Manage Custom 
Sizes...”
a new window will pop up 

a. Press the + button to create a 
new paper size

b. Enter Width / Height
- We recommend making your 
“Paper Size” 1-2in larger 
than your image size, to 
accommodate a nice margin, or 
allow for crop/trim marks
- Width should be 24in or less
- Height (length off of the roll) 
should be between 5- 96 in

c. Enter Non-Printable Area 
- These are your margins, this 
area cuts into the defined 
paper size, it does not add area 
outside of the Paper Size
- Set all to 0 to print Borderless
(fully edge to edge on paper)

Hit OK when done 
Continue with Step 7 in 
your print settings



Use these additional/alternate settings, while following the Print Instructions listed 
on Pages 6-11 for all other settings.

Paper Size: Create Custom Paper Size
Width/Height: exact size of your image
Non-Printable Area: 0 in for all sides

Printer Settings: 
Page Setup: Roll Paper - Borderless, Auto Expand

Roll Paper Settings:
Auto Cut Settings: Double Cut
Borderless Enlargement Setting: Max

Creating a borderless print is only possible if your image is 24” in either width or height. 

Please note: Allow for at least .125” bleed - printing borderless will enlarge your image 
slightly to bleed over the edges, you will lose those edges of your image to trimming.

Borderless Printing



Advanced Black and White (ABW) mode on Epson printers is one of the best and easiest  
ways to print high quality, neutral toned, B&W prints. 

1. Follow pages 1-6 of this manual 

2. File > Print
Printer: EPSON SC-P7500 Series
Color Handling: Printer Manages Colors

3. Print Settings...
Follow steps 5-6
See page 12 for custom paper sizes

4. Color Matching
Select EPSON Color Controls

5. Printer Settings
Basic tab

Media Type: Choose your paper type
Color: Advanced B&W Photo
Color Toning: Neutral
Print Quality: Your choice - 
We recommend 1200-2800dpi
High Speed: Prints faster, may reduce 
quality

Advanced Color Settings tab
Tone: Dark

6. Save
  Continue on page 11

Advanced B&W Printing



1. View > Proof Setup > Custom...
 - Device to Simulate: choose appropriate paper type
 - Uncheck all boxes, hit OK

- Turn printer on, log in to computer
- Download your fully Packaged INDD Folder to Temp Storage, open from that location

2. File > Print
 Printer: EPSON SC-P7500 Series
   Color Management tab
 Print: Proof
 Color Handling: Let InDesign...
 Printer Profile: Your paper type
 Uncheck Simulate Paper Color
   Setup tab
 Rotate orientation if necessary
 Page Position: Centered

3. Page Setup... button (lower left)
 see page 9 for pre-set sizes
 see page 12 to create custom size

4. Printer... button
 Expand window with “Show Details”
 Layout dropdown to Printer Settings
 see page 10
5. Hit Print (and again)

Please note: 
If you are printing a multi-page document, or double-sided photo book, we reccommend 
using sheets vs. roll paper. We sell paper by the sheet in the SB (double-sided matte 
finish paper is available), or you are welcome to provide your own. 
If printing double-sided, let the prints dry for at least an hour before printing other side. 

Printing From InDesign

https://intranet.mcad.edu/kb/packaging-indesign-file


1. View > Proof Setup > Customize...
 - Device to Simulate: choose paper type (MK) 
 - Rendering Intent: Relative Colormetric
 - Uncheck all boxes, hit OK

- Turn printer on, log in to computer
- Download your Packaged AI Folder or EPS file to Temp Storage before opening

2. File > Print
 Printer: EPSON SC-P7500 Series
  Color Management tab
 Color Handling: Let Illustrator...
 Printer Profile: Your paper type
 Rendering Intent: Relative Colormetric
  General tab
 Choose Artboards to print or ignore
 Rotate orientation if necessary

3. Page Setup... button (lower left)
 see page 9 for pre-set sizes
 see page 12 to create custom size

4. Setup... button
 Expand window with “Show Details”
 Layout dropdown to Printer Settings
 see page 10
5. Hit Print (and again)

Please note: 
If you are printing a multi-page document, we reccommend using sheets vs. roll paper. 
We sell paper by the sheet in the SB, or you are welcome to provide your own. 
If printing double-sided, let the prints dry for at least an hour beforae printing other side. 

Printing From Illustrator



Ink Low Warning
• An INK LOW message on the printer’s LCD display is not cause for concern
• When the ink cartridge is empty, printing will stop and the display will say INK OUT, 

the ink cartridge can be replaced and printing will resume seamlessly
• You may have to use a full ink cartridge in order to run a head cleaning, please 

replace the older/low ink cartridge after cleaning 

Troubleshooting

Replacing Ink
shake cartridge well

File Not Printing

If you went through all of the printing instructions accurately, hit print, and nothing is 
happening it could be a few different things.  

Do you have enough money in your Papercut Account? 
 papercut.mcad.edu

Paper too low to print? 
 At 4 feet or less, the printer will wait for a new roll before resuming with 
printing, please notify SB staff if the paper appears to be too low to complete your 
print job - the paper length remaining will appear on the LCD screen on the printer

Did you set up your custom paper size with the WIDTH at 24”? 
 The printer may crop your file weirdly, sending out a small portion, or startle you 
by shooting out a bunch of paper without a print) if you set the width over 24”. 
Rotate your image, and set your width to no more than 24” - length may be up to 96”

You are welcome to replace ink cartridges when necessary! We will leave replacement 
inks near the printer if we notice that it is getting low. 
Ask SB staff to assist you if you do not feel up to the challenge.

https://papercut.mcad.edu:9192/user


File too big? 
 If you have an extra large image to print (even if the file size is not extraordinary) 
it will take extra long to process and print, so please allow for that. 
 If your file size is particularly large (1gb or higher), please make sure to flatten 
your file, delete any channels/adjustment layers.
 File should be in 8 bit mode rather than 16 bit.
 DPI should be 300 or around there (no less than 150, no more than 400).

Is your file on the Temp Storage on the computer?
 If you are printing from a connected server or external hard drive, you can 
experience file corruption and server interruptions that can cause files to not print, or 
result in your print looking strange.

Nozzle check or head cleaning cycle not complete? 
 Wait for it to complete, and return to the “ready” status menu

Printer not on? 
 LOL it happens more than you would think

When in doubt, shoot the SB an email (sbureau@mcad.edu), pop over to the Service 
Bureau for extra assistance, or make an appointment for a printing demo.

mailto:sbureau%40mcad.edu?subject=Epson%20Printing%20Assistance%20Please
https://calendly.com/mcadsb


These printers can reproduce a very wide range of colors, but you will find that there are certain 
tones that are not possible to translate from screen to print.

You always want your artwork files to be in RGB to give you 
the widest range of colors available on the screen. 

But remember that the printer uses CMYK inks to reproduce 
the colors seen on your screen. 

We do a “soft proof” with our preferred paper type, to see how our colors will translate. 
(View > Proof Setup step in print instructions)

Most of the time, you won’t notice much of a difference, if any!

If you do notice a difference, it means that the printer cannot reproduce that color on that paper 
type (PK finish papers will give a slightly wider color range), and you will need to make some 
adjustments to your file to get the color closer to what you prefer. 
We have noticed the most trouble with deep purpley-blue colors.

Try View > Gamut Warning to see what colors might be outside of the color gamut (or available 
color range).

Colors out of gam
ut

Standard view
Color Gamut Warnings



Epson Printer Errors
Head Strike (see “ink smudges”)
Print head causes streaks, commonly due to 
excessive curling or thickness of paper.
Recommended to flatten paper, adjust platen gap 
and wait for excess ink on print heads to dry.

Directions print head moves 

 (see “nozzle check”) Banding
Clogged print nozzles cause one or more color to 

not print, causing stripes and missing colors.
Run a nozzle check before printing to aviod. 

Remedy by running head cleaning, may need to run 
cleaning more that once. 

D
irections p

rint head
 m

oves 

Head Strikes or Banding



Print Appears Too Dark

If your prints are coming out really REALLY dark (much darker than the screen), you 
might be forgetting one, little, easy-to-forget step.

Color Management needs to be set before continuing to Print Settings:

Color Handling: Photoshop Manages Colors.

Printer Profile: Epson SC-P9500-7500 Enhanced Matte Paper

Often the Printer Profile is left at “Working RGB – Adobe RGB 1998,” which is wrong.  

Commonly 
Overlooked

Computer Issues
 If you are experiencing issues with the computer, please contact computer 
support, or stop by the Help Desk during business hours.

Application Knowledge
 If you need assistance with Adobe programs (beyond print setup) such as; 
file setup and creation, image resizing, color adjustments, or assignment specific 
issues and troubleshooting. Please refer to your professor/instructor, or make an 
appointment with the Learning Center.


